For a deeper look into our Elektron API, look into:

Overview |  Quickstart |  Documentation |  Downloads |  Tutorials |  Articles

question

Upvotes
Accepted
7 3 1 4

State: Closed/Suspect/Login rejected, exceeded maximum number of mounts per user - text: "Exceeded maximum number of mounts per user.

I try to use ETA API to pull market price data via EZD, it worked before, but today when I try to pull price data for EUR=, I kept getting "Exceeded maximum number of mounts per user".

Log from ezd:

The EZD process has intercepted a login response failure to the client from host amers1.streaming-ec.cp.thomsonreuters.com on socket 10.  Reason from source:Exceeded maximum number of mounts per user.

Log from ETA API

State: Closed/Suspect/Login rejected, exceeded maximum number of mounts per user - text: "Exceeded maximum number of mounts per user.

From my ezd_licensefile.txt, there are two values from ILA_LIST, and I only assigned one to a user in my user_list.txt file. So I'm wondering why I'm getting the above ERROR message.

Could you help address the issue?

Thanks,

Jerry

elektronrefinitiv-realtimeelektron-sdkmarket-by-price
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

11 Answers

Upvotes
Accepted
32.2k 40 11 19

Hello @jmao1,

I think the log record:

"<ezd.snkRsslServer.14002: Debug: Wed Aug 15 16:07:14.593951 2018>
RSSL disconnect from host "" at address on channel 6.
Reason: rsslInitChannel() failed with code -1. Text: <Impl/ripcsrvr.c:3357> Error: 1007 Unknown connection type."

is indicative.

It looks like this connection is not recognized. Have you tested with rmdstestclient before? This is the demo client that comes with ezd and is in folder demo.

I suggest to restart daemon again, start fresh, make sure no connection attempt is logged in EZD log (i.e. nothing else is attempting connection to you EZD ahead of this testing), and then test with rmdstestclient, to see if it can connect and consume data on RSSL, or encounters the same issue.

For example:

rmdstestclient -h localhost -S ELEKTRON_DD -f items.txt -X -v

With file items.txt stored in the same folder and containing a single line with a valid permissioned item RIC

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
32.2k 40 11 19

Hello @jmao1,

The number of max mounts is the maximum number of simultaneous connections allowed. If you have 2 valid assigned ILAs configured for your user in user_list, it should be 2. if only one, it is likely only one, so, if there is one mount established already, the next request, yours, will fail, with the message that you see.

You may be able to see the connects and disconnects of the clients in your EZD log, if your EZD is currently configured to log them. If not, you may have to reconfigure logging to high, and restart EZD to see the other application reconnect and have it reflected in the EZD log.

This way you will be able to understand what application is currently mounting to your EZD.

Hope this helps.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

@zoya.farberov

*ezd*logger*file : /spare/local/reuters/data/ezd.log

*ezd*logger*install_file_action : True

*ezd*logger*install_stderr_action : False

*ezd*logger*install_system_action : False

*ezd*logger*logDtMsgTogether : False

*ezd*logger*max_bytes : 3000000

*ezd*logger*max_swapfiles : 0

*ezd*logger*microSecTimeStamps : true

*ezd*logger*selector : *.debug

*ezd*logger*timeStampFormat : %a %b %d  %H:%M:%S %Y

*ezd*debugTrace : False

*ezd*dumpIncoming : False

*ezd*dumpOutgoing : False

which one should I change so that I'm able to see other application?

Thanks!

Upvotes
32.2k 40 11 19

Hello @jmao1

Please go:

ezd*debugTrace : True

*ezd*dumpIncoming : True

*ezd*dumpOutgoing : True

After ezd is restarted:

1. You should see your failed attempt to mount reflected in the app log.

2. If the other application (s), successfully reconnect after restart, that should be reflected in the ezd log as well.

Let us know how this goes for you, log level set, ezd restart, and your app reconnect, if the ezd log is helpful now and you are able to proceed.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
7 3 1 4

@zoya.farberov

I have set the log level and restarted ezd. But I don't see any other applications successfully reconnect after the restart, and I still got the same error as before.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
32.2k 40 11 19

Hello @jmao1,

Do you see the restart in your EZD log?

Do you see your mount attempt in EZD log?

Then you should see any other app connect attempt, and response by EZD, successful or not?

As far as you know, no other app is currently running and connected?

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
7 3 1 4

ezd.txt@zoya.farberov Sorry for the late reply. I was on vacation.

I still have the issue. Please see my ezd log in attachment. And following is the error message that I got from the market price data consumer.

16:07:09.588790 INFO State: Closed/Suspect/Login rejected, exceeded maximum number of mounts per user - text: "Exceeded maximum number of mounts per user."
16:07:09.588794 ERROR Connection down, reconnecting.  Channel fd=9
16:07:14.594812 INFO Connection up! Channel fd=9

ezd.txt (12.2 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
32.2k 40 11 19

Hello @jmao1,

I see repeated connections in your log today. I also see multiple "Error: 1007 Unknown connection type." I also see connection "from host "" ". It appears that something is not reconglinzed on your connection.

What connection type(s) were configured on the install on EZD:

Is RSSL enabled (one can verify this in ezd.cnf, i.e. "enableRsslServer : True")

Latest ETA is OMM only, i.e. RSSL.

What port are you connecting on? the default port for RSSl is 14002.

If RSSL is enabled on EZD, on default port 14002, and your ETA app is attempting to connect via RSSL on port 14002 it should work.

Is not right that host you are connecting from (looks like a localhost) is not recognized. Are you on Linux or on Windows?

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
7 3 1 4

@zoya.farberov I'm on Linux, and it worked before, but one day it suddenly had this issue.

RSSL is enabled, and I'm using port 14002, localhost, ELECTRON_DD

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
32.2k 40 11 19

Hello @jmao1,

Were there any changes made on the Linux machine itself, after it has last worked properly?

The message “from host ""” usually means that host is not resolved. Is it able to resolve itself as localhost?

Try testing:

ping localhost

If not, do you see /etc/hosts has an entry like:

127.0.0.1 localhost.localdomain localhost <assigned_ip> < hostname>

Let us know what you find out

Thanks

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
7 3 1 4

Hi @zoya.farberov

I believe there is nothing changed on the Linux machine, and `ping localhost` works for me.

But the error is about exceed maximum mounts per user, how does localhost effect that?

Thanks,

Jerry

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
7 3 1 4
@zoya.farberov

I tried use rmdstestclient, and it works. I will investigate my own code and setup. Thanks for the help!

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.