question

Upvotes
Accepted
21 1 0 0

Data not returned for inactive instruments on raw data extraction

Hi,

i'm running a historical raw data extract request:

{"ExtractionRequest":{
  "@odata.type":"#ThomsonReuters.Dss.Api.Extractions.ExtractionRequests.TickHistoryRawExtractionRequest",
  "IdentifierList":{
    "@odata.type":"#ThomsonReuters.Dss.Api.Extractions.ExtractionRequests.InstrumentIdentifierList",
    "InstrumentIdentifiers":[
      {"Identifier":"USDSB3L2Y=TWEB","IdentifierType":"Ric"},
      {"Identifier":"EURAB6E2Y=TWEB","IdentifierType":"Ric"},
      {"Identifier":"GBPSB6L2Y=TWEB","IdentifierType":"Ric"}
    ],
    "ValidationOptions":{"AllowHistoricalInstruments":true,"AllowInactiveInstruments":true},
    "UseUserPreferencesForValidationOptions":false
  },
  "Condition":{
    "MessageTimeStampIn":"GmtUtc",
    "ExtractBy":"Ric",
    "SortBy":"SingleByRic",
    "DomainCode":"MarketPrice",
    "ReportDateRangeType":"Range",
    "QueryStartDate":"2019-01-10T00:00:00.000Z",
    "QueryEndDate":"2019-01-10T23:59:59.999Z",
    "DisplaySourceRIC":true,
    "Fids":"22,25,875,1010,1021,3349,2286,14265"
  }
}}

However, even setting the allow inactive instruments i get:

Instrument <RIC,EURAB6E40Y=TWEB> expanded to 1 RIC: EURAB6E40Y=TWEB.
Instrument <RIC,GBPSB6L40Y=TWEB> expanded to 1 RIC: GBPSB6L40Y=TWEB.
Instrument <RIC,JPYSB6L40Y=TWEB> expanded to 1 RIC: JPYSB6L40Y=TWEB.
Instrument <RIC,EURAB6E50Y=TWEB> expanded to 1 RIC: EURAB6E50Y=TWEB.
Instrument <RIC,GBPSB6L50Y=TWEB> expanded to 1 RIC: GBPSB6L50Y=TWEB.
Total instruments after instrument expansion = 62
Manifest: #RIC,Domain,Start,End,Status,Count
Manifest: EURAB6E10Y=TWEB,Market Price,,,Inactive,0
Manifest: EURAB6E12Y=TWEB,Market Price,,,Inactive,0
Manifest: EURAB6E15Y=TWEB,Market Price,,,Inactive,0
Manifest: EURAB6E20Y=TWEB,Market Price,,,Inactive,0
Manifest: EURAB6E25Y=TWEB,Market Price,,,Inactive,0

In the response body, and no data returned.

There is data in this period

Am i missing a parameter here?

tick-history-rest-apihistoricalrest-apichain-ric
untitled.jpg (71.8 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
21 1 0 0

Aha, so that does work,

guess by default fids param here asks for only messages that contain all the listed FIDs by default.

added
FidDisplayOption: Matching;FidListOperator:OR
and we are in business


thanks!

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
29k 33 11 15

Hello @i.am.tobias.harper,

Try removing fids spec from your request, i.e.:

{"ExtractionRequest": {"@odata.type":"#ThomsonReuters.Dss.Api.Extractions.ExtractionRequests.TickHistoryRawExtractionRequest", "IdentifierList":{"@odata.type":"#ThomsonReuters.Dss.Api.Extractions.ExtractionRequests.InstrumentIdentifierList", "InstrumentIdentifiers":[{     "Identifier":"USDSB3L2Y=","IdentifierType":"Ric"},     {"Identifier":"EURAB6E2Y=","IdentifierType":"Ric"},     {"Identifier":"GBPSB6L2Y=","IdentifierType":"Ric"}], "ValidationOptions":{"AllowHistoricalInstruments":true,"AllowInactiveInstruments":true},"UseUserPreferencesForValidationOptions":false}, "Condition":{"MessageTimeStampIn":"GmtUtc","ExtractBy":"Ric","SortBy":"SingleByRic","DomainCode":"MarketPrice","ReportDateRangeType":"Range","QueryStartDate":"2019-01-10T00:00:00.000Z","QueryEndDate":"2019-01-10T23:59:59.999Z","DisplaySourceRIC":true}}}

It appears that that the updates that have occurred did not update the fids you have specified in the request.

If I run your request as is, I get back nothing, same as you. If I remove fids from the condition, I get the updates back.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.