For a deeper look into our DataScope Select REST API, look into:

Overview |  Quickstart |  Documentation |  Downloads |  Tutorials

question

Upvotes
Accepted
11 7 2 3

Wrong timestamp (LocalExchangeTime) in Intraday Summaries Extraction Request

I'm extracting tick data for certain RICs by posting appropriate Extraction Request with MessageTimeStampIn" : "LocalExchangeTime". The following is the Extraction Request

{
   "ExtractionRequest" : {
      "@odata.type" : "#ThomsonReuters.Dss.Api.Extractions.ExtractionRequests.TickHistoryIntradaySummariesExtractionRequest",
      "ContentFieldNames" : [
         "Close Ask",
         "Close Bid",
         "High",
         "High Ask",
         "High Bid",
         "Last",
         "Low",
         "Low Ask",
         "Low Bid",
         "No. Asks",
         "No. Bids",
         "No. Trades",
         "Open",
         "Open Ask",
         "Open Bid",
         "Volume"
      ],
      "IdentifierList" : {
         "@odata.type" : "#ThomsonReuters.Dss.Api.Extractions.ExtractionRequests.InstrumentIdentifierList",
         "InstrumentIdentifiers" : [
            {
               "Identifier" : "AULM8",
               "IdentifierType" : "Ric"
            }
         ],
         "ValidationOptions" : {
            "AllowHistoricalInstruments" : 1
         },
         "UseUserPreferencesForValidationOptions" : 0
      },
      "Condition" : {
         "MessageTimeStampIn" : "LocalExchangeTime",
         "ReportDateRangeType" : "Range",
         "QueryStartDate" : "2018-05-08T00:00:00Z",
         "QueryEndDate" : "2018-05-09T00:00:00Z",
         "SummaryInterval" : "OneMinute",
         "TimebarPersistence" : 1,
         "DisplaySourceRIC" : 1
      }
   }
}

Data is correctly returned. However, sometimes the timestamp is not in LocalExchangeTime for a row (for rest of the rows its correct). For example, see below

AULM8,,Market Price,2018-05-08T18:58:00.000000000-05,Intraday 1Min,.......
AULM8,,Market Price,2018-05-09T01:59:00.000000000+02,Intraday 1Min,.......

For AULM8, in the last row, although the value of the timestamp is correct, the Local Exchange timestamp should've been

2018-05-09T18:59:00.000000000-05 instead of 2018-05-09T01:59:00.000000000+02, since it's an US instrument.

Note: I've noticed this behavior in certain other instruments too (AULU8, FLGM8). Could you please check why the timestamp is not correctly returned in Local time sometimes?

Thanks!

dss-rest-apidssdatascope-selecthistoricaltime-stamp
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
31.8k 37 11 19

Hello @ggoli,

The fix was deployed. I run a test on my side, the result looks good. Could you please verify on your side as well?

Thanks,

-Zoya

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Working now. Thanks for the fix!

Upvote
31.8k 37 11 19

Hello @ggoli,

I was able to reproduce the issue you are seeing.

We have opened case #06570129 to investigate it on the content side.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hi @ggoli ,

Not yet, but will keep posted here if any info

@zoya.farberov Okay. Thanks!

Hi @zoya.farberov, is there any update on this?