question

Upvotes
Accepted
3 0 1 2

Handshake failed: "Forbidden: No session"

I'm following the Side by Side Integration API Quick Start.

  • I have Eikon running, I'm logged in
  • I have generated app key, with "Side by Side API" type
  • ping was successful
  • but the handshake request:
{
    "command": "handshake", 
    "productId": "xxx",
    "appKey": "yyy"
}

fails with 403 status and message "Forbidden: No session". Eikon shows no prompt.

Any idea what am I doing wrong?

Thanks!

side-by-side-apisessionhandshake
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
13.2k 61 39 63

Hi @petr.doubek,

I just went through the process and discovered that the instructions didn't mention to ensure JSON is selected as the format of the text. For example, ensure the following is selected:

Let us know if this helps.

thanks.


ahs.png (8.3 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
3 0 1 2

Thanks, that was it! Actually it is mentioned ("Ensure raw data is selected with JSON"), I overlooked it as it isn't in bold font as the other options that have to be set :-)

One change I had to make to the message: ProductId -> productId

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hi @petr.doubek,

I also overlooked this. However, I updated the quick start so it was a little more obvious.