question

Upvotes
Accepted
5 2 3 5

Interactive provider failed after TREP migration

Hi all,

we have an ADH/ADS service for use with Interactive-Provider implemented on RFA 8.1.

And for TREP and service have been setup via Reuters everything works fine on TREP 2.6.1.

After reuters support migrateTREP to version 3.2. no one was able to bring up our service back to life.

The reuters support team has checked the service with rsslSinkApp which displayed our service in state 'Up' and details of published data. But they failed with ADH/ADS.

Their monitors did not show the service in state 'Up'.

Does anyone knows anything about bugs in RFA 8.1 / TREP 3.2 or (un-)documented installation-instructions the reuters support team did not take care about?

Or ist anyone using InteractiveProvider RFA 8.1 (rfa8.1.0.L1.linux.rrg/Examples/Provider_Interactive)

with TREP 3.2?

Thanks for your help,

Thomas


treprfarfa-apiinteractive-provider
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvote
Accepted
11.3k 25 8 14

Hi @Thomas Wolf,

I'm able to replicate the issue. It seems that your provider application encodes incorrect type of string, StringUTF8, for "Name", "Vendor" and "ItemList" elements in the source directory refresh message. Please modify the application to encode the elements with StringAscii instead.

 <elementEntry name="Name" dataType="RSSL_DT_UTF8_STRING" data="PDV"/> <elementEntry name="Vendor" dataType="RSSL_DT_UTF8_STRING" data="pdvfs"/> 

You can refer to RDM Usage Guide document for data types as follows.


nameelement.png (13.6 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Solved! Thanks a lot. I thought about the directoryMsg too but would have never question the string data type to cause the trouble.

Upvotes
25k 87 11 23

Hi @Thomas Wolf

Were there any clues in the ADH Log files?

Also, did you enable RSSL message trace in your config for your RSSL_PROV type connection?

\Connections\Connection_RSSL_PROV\connectionType	= "RSSL_PROV"
\Connections\Connection_RSSL_PROV\rsslPort			= "14002"
\Connections\Connection_RSSL_PROV\traceMsgToFile	= true
\Connections\Connection_RSSL_PROV\traceMsgFileName	= "<yourfilename>"

Does the RSSL trace provide any pointers?

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
5 2 3 5

Hi all,

we could track down the problem a little bit. It seems as if the adh behaves different.

If we change the adh from verion 2.6.1 to 3.2.1 leaving all other parameters unchanged there is no longer a message 'The application sent a service up state.' in adh.log, only the login success. Starting adh in the old version every thing works fine again.

I have attached tracing of provider and other details in tracing.txt

Manybe the provider has to report service state explicitly now?

Provider implemented using:

C++ / rfa8.1.0.L1.linux.rrg / OL7_64_GCC482

Thomas.


tracing.txt (19.3 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.