question

Upvotes
Accepted
1 1 3 5

Level2 Refresh Complete and Update messages.

We subscribe to Level2 and cache the book in our application. We noticed that sometime we receive CLAER_CACHE and do not receive REFRESH_COMPLETE for a Level2 Market Maker domain. After few minutes we start receiving Updates messages without receiving REFRESH_COMPLETE. Is this an expected behavior, if yes then how do we know that we got the initial book completely. We usually notice this happens for RICs which are subscribed before market open.

We rely on REFRESH_COMPLETE as an indication of completion of book message. Please share if you experienced such behavior, if yes any suggestions/work-arounds.

treprfarfa-apilevel-2
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hi @anil.kalra,

Are you able to replicate the issue after the trace? Can you share the file?

Hi @anil.kalra,

Are you able to replicate the issue after enabled the trace? Can you share the file?

@anil.kalra

Hi,

Thank you for your participation in the forum.

Are any of the replies below satisfactory in resolving your query?

If yes please click the 'Accept' text next to the most appropriate reply. This will guide all community members who have a similar question.

Otherwise please post again offering further insight into your question.

Thanks,

AHS

Hello @anil.kalra,

We have not heard back from you.

Please be informed that a reply has been verified as correct in answering the question, and has been marked as such.

Thanks,

-AHS

Upvotes
Accepted
25.3k 87 12 25

Hi @anil.kalra

I recommend you enable low level trace for the RSSL connection and capture the above occurence in the trace.

You can then raise a Premium Support ticket and provide the Trace files so they can investigate this off line in more detail - involving the Elektron team if required.

The config parameters required to enable the low level trace depends on which RFA version you are using C++ / Java / .NET

For RFA C++ or .NET see this existing post on how to enable trace.

For RFA Java you will need to set the ipcTrace Flag in your config for the RSSL connection you are using e.g.

<node name="consConnection">
      <map>
           <entry key="connectionType" value="RSSL"/>
           <entry key="serverList" value="<yourServer>"/>
           <entry key="portNumber" value="14002"/>
           <entry key="mountTrace" value="true"/>
           <entry key="ipcTraceFlags" value="7"/>
           <entry key="logFileName" value="rfa.log"/>
      </map>
 </node>   
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
1 1 3 5

Hi @Umer Nalla Thanks for the reply. I will enable the trace and capture the data.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
24.6k 54 17 14

Hello @anil.kalra

Did the problem still persist in your environment? If so, can you share us the trace file?

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.