question

Upvotes
Accepted
1 0 0 0

rfa.session.position parameter does not accept hostname because an error A21 A required argument was NULL

We have an issue with rfa.session.position parameter in RFA Omm configuration. While we try to using hostname we are getting this error from ADS/DACS system:
A21 A required argument was NULL

We need to use host name instead of ip address it is required in our load balancing system.

Our current configuration after setup ip address which works.

# Reuters Rfa Omm configuration
# These properties can be overriden in RTBS source configuration screen.
rfa.session.name=Murex::RSSL
rfa.session.username=lala
rfa.session.position=x.x.x.182
rfa.session.application=185

treprfarfa-api
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
7.6k 15 6 9

@Kamil.Walewski1

The A21 message was generated by the DACS component. The consumer application required to pass in a valid format of the DACS position(IP/hostname of the consumer) in the login message like the sample format provided by Umer. You can refer to the information from the RDM Usage Guide provided in the RFA Package. Below is the detail from the RDM Usage Guide.


a21.png (10.4 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
24.9k 87 10 22

Hi @Kamil.Walewski1

You mention load balancing - please note that the position parameter should be the hostname or IP address where the application is actually being run - and not the server you are trying to connect to.

Also, it should be of the format "ip addr/hostname" or “ip addr/net” e.g.”192.168.1.1/net” or "192.168.1.1/mylocalhostname"


icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.