question

Upvotes
Accepted
51 9 17 13

Can't install sqsQueue library for Python to retrieve Research Alerts via Research API using the sample python scripts.

To try retrieve Research Alerts messages via EDP Research API using the sample python scripts, I tried to install sqsQueue library by executing the following command on terminal on macOS, but can't install it receiving the following error message..

Can you please let me know how to resolve this?


Command executed

pip3 install sqsQueue


Error message

"Could not find a version that satisfies the requirement sqsQueue (from versions: ) No matching distribution found for sqsQueue"


Screenshot

rdp-apirefinitiv-data-platformresearch
1575869583274.png (52.2 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
11.3k 25 8 14

@hiroko.yamaguchi,

If you are using the Python example here, the "import sqsQueue" in researchAlert.py is to link to an internal file (sqsQueue.py). For SQS access, you need to install "boto3" which is stated in this tutorial.


1575874810976.png (11.9 KiB)
1575874845057.png (13.8 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvote
7.6k 15 6 9

@hiroko.yamaguchi

It seems to be sqs_queue?
pip install sqs_queue

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.