question

Upvotes
Accepted
791 10 8 14

RFA client load balancing

Trying to get RFA Client Load Balancing working at a client without Warm Standby but it’s not working the way I expected. It is redirecting my mount, but it seems to point me to the ADS with the highest number of mounts. I was able to replicate the issue in my lab by running three instances of ADS on three different TCP ports. Here is the parameters that configure the Load Balancing on the ADS

*ads*enableConnectConfig: True *ads*disableLocalRedirect : False *ads*connectConfig*ron.active : labads|14002,labads|14012,labads|14022 *ads*connectConfig*ron.standby : *ads*discoveryNetwork : eth1;224.5.5.5|7100 *ads*logDiscoveryEvents : True *ads*supportWarmStandby : False

I’m using StarterConsumer from RFAC++ 7.5.1.L1 with default settings. No matter which ADS I point the application to, it always picks the one with the most mounts.

elektronrefinitiv-realtimetreprfaADS
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Upvotes
Accepted
301 8 23 30

Regarding your query on RFA client load balancing. try adding the numStandby parameter as follow into the rmds.cnf

*ads*connectConfig*ron.standby : *ads*connectConfig*ron.numStandby: 0

Regarding the client’s configuration, the standby list is empty so the numStandby should be configured to zero as well. I consulted this with the RFA support team and they stated that if the numStandby is more than 0, the RFA consumer application will search for the server which is enabled the warm standby. If no server is enabled, the RFA consumer application will choose the last server in the list it received which is the one that have the maximum load.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.