For a deeper look into our Eikon Data API, look into:

Overview |  Quickstart |  Documentation |  Downloads |  Tutorials |  Articles

question

Upvotes
Accepted
1 0 1 1

eikonapir - error 502

I am new in eikon api for R. When I try to get data I have this error:

> get_data("MSFT.O","TR.ISIN", debug=TRUE)
[1] "Request *************************************"
{"Entity":{"E":["DataGrid"],"W":{"instruments":[["MSFT.O"]],"fields":[{"name":["TR.ISIN"]}]}}} 
[1] "Response *************************************"
[1] "<!DOCTYPE html>...Requested URL:\r\n\t\t\t</div>\r\n\t\t\r\n\t\t\t<div class=\"span6\">\r\n\t\t\t\thttp://localhost:9000/api/v1/data\r\n\t\t\t</div>\r\n\t\t</div>\r\n\r\n\t\t<div class=\"row\">\r\n\t\t\t<div class=\"span2 label\">\r\n\t\t\t\tReason:\r\n\t\t\t</div>\r\n\t\t\r\n\t\t\t<div class=\"span6\">\r\n\t\t\t\tInvalid argument\r\n\t\t\t</div>\r\n\t\t</div>..."
[1] "Response status *************************************"
[1] 502
Error in print.default("HTTP Error, code= ", response$status_code, sep = "") : 
  invalid 'digits' argument

I think it used to work several weeks ago.

There is a proxy in my enviroment but I do not have to explicitly set it in order to install packages or download files in R.

http://localhost:9000/ping?all

{"port":9000,"mode":"eikon4","pid":30764,"hasSecure":true,"startedTime":"Wed May 13 2020 09:25:01 GMT+0300 (FLE Daylight Time)","subApps":[{"path":"/heap"},{"path":"/ping"},{"path":"/sxs","data":{"hasSecure":true,"sxsApps":{}}},{"path":"/api"},{"path":"/sxs/v1/services/messenger"}]}

http://localhost:9000/api/v1/

{"code":404,"message":"Not Found","statusMessage":"Not Found"}
eikoneikon-data-apipythonworkspaceworkspace-data-apirefinitiv-dataplatform-eikoneikon-data-api-r
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
47.4k 111 44 60

@svilen

You can do a quick check with the curl command, as shown below.

curl -H "Content-Type: application/json" -H "x-tr-applicationid: <app_id>" -L -X POST -v -d "{\"Entity\": {\"E\": \"DataGrid\",\"W\": {\"fields\": [{\"name\": \"TR.ISIN\"}],\"instruments\": [\"MSFT.O\"]}}}" http://localhost:9000/api/v1/data

Please change <app_id> to your application id.

If the curl command gets the same error code 502, it could be a problem in the machine's settings.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

@jirapongse.phuriphanvichai I've checked with the curl command (outside R) and I get the same error message. Could you please tell me which machine's settings could cause the issue?

You mentioned about proxy in the question. It could be a proxy or firewall.

If you know the proxy settings, you can try to run the curl command with the proxy parameters.

1592997523529.png (91.2 KiB)
Upvotes
7.4k 10 6 8

Hi @svilen if you are using the eikonapir library - you would need to uninstall and reinstall a new updated library which fixed some bugs - details are available in this post

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

@jason.ramchandani I reinstalled the library but it did not helped and I have the same error.

Have you tried

set_proxy_port(9000L)

Yes, but with no success

Upvotes
29k 33 11 15

Hello @svilen,

In addition to the answer by @jason.ramchandani, please also note, that Eikonapir is not officially supported by Refinitiv. You can reach the creator for support directly at EikonAPIR on GitHub.

As an additional approach, and as environment setup issue appears to be likely, you may find article Eikon Data API(Python) Troubleshooting to be of help, especially so if you have any Python experience. If this is the case, you may also be on an easier path by following Quick Start For EDAPI Python. Once you are seeing the results in Python, move to R next.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.