question

Upvotes
Accepted
13 2 4 6

System error (107) - ETA API (Running on Docker) cannot establish connection on RCC.

Hi Community,

I have had troubles to connect my RTSDK container on RCC using ETA API , but the strangest part is It's able to connect when it use EMA API. In both cases I've used samples to post data available here.

I've tried to build and test among bellow versions of Real-Time-SDK (Elektron-SDK):

  • Elektron-SDK-1.4.0.L1 (from Developer Portal)
  • Elektron-SDK-1.5.0.L1 (from Developer Portal)
  • RTSDK-2.0.0.L1 (from Developer Portal)
  • Real-Time-SDK (from GitHub)


And all of them I get errors regarding connection.

I’ve also tried to run a couple example without add VAConsumerContribution sample on ETA, but I keep getting the same System error (107), don’t matter what VIP Service DSN address or sample that I use

I ran this openssl command openssl s_client -connect contrib01-emea1.int.refinitiv.com:443 -tls1_2, to see if container was able to reach out RCC and it seems that could connect on address. You can find the attached file with the result. result openssl command.txt

I’m attaching one of my Dockerfiles to you analyze how I’m building those versions. Maybe I’m not including some needed package, I don’t know!

I've tried to connect on all Service Address available here (Test and Production Environment of Internet and Delivery Direct Service Address).

Bellow, I’m leaving some information else about my environment:

  • OS Host: Windows 10 Professional
  • Docker’s version is: Docker version 19.03.13, build 4484c46d9d.
  • OS Docker Image:
    • NAME="Oracle Linux Server"
    • VERSION="7.9"
    • ID="ol"
    • ID_LIKE="fedora"
    • VARIANT="Server"
    • VARIANT_ID="server"
    • VERSION_ID="7.9"
    • PRETTY_NAME="Oracle Linux Server 7.9"
    • ANSI_COLOR="0;31"
    • CPE_NAME="cpe:/o:oracle:linux:7:9:server"
    • HOME_URL="https://linux.oracle.com/"
    • BUG_REPORT_URL="https://bugzilla.oracle.com/"

    • ORACLE_BUGZILLA_PRODUCT="Oracle Linux 7"
    • ORACLE_BUGZILLA_PRODUCT_VERSION=7.9
    • ORACLE_SUPPORT_PRODUCT="Oracle Linux"
    • ORACLE_SUPPORT_PRODUCT_VERSION=7.9


elektronrefinitiv-realtimeelektron-sdkrrteta-apielektron-transport-apidocker
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Bellow you may see I trying connect on RCC using samples of ETA.

vaconsumer.jpg (88.6 KiB)
consmod1a.jpg (31.2 KiB)

One of my Dockerfiles.

Dockerfile.txt

dockerfile.txt (1.3 KiB)

Hi @Bruno.Leal,

Do not think this type of question will have a ready answer from anyone on the forums.

Just confirming here:

  • As you are getting dictionaries errors first (I do not), if you copy dictionaries into folder, the error does not change?
  • EMA contrib is running successfully on the same docker instance? Or do I misunderstand?

If that is the case, I would first verify, that all the parameters that you are passing to EMA contrib via EmaConfig.xml and code, are making their way into ETA contrib via command line parameters. As your "Connections" output looks different. Mine looks like

Connections:
        contrib1-emea1.uat.platform.refinitiv.com:4
        Contribution Channel Details:
                tunnel: TRUE
                trceUser: MYUSER
                trcePass: MYPASSWORD
                trcePostItem: MYITEM
  • Also, realizing this is extra work on your side, but to narrow down the possibilities on the issue, do you have another machine, such as personal box, and are you able to run ETA contrib without docker involved with exact same parameters?

1 Answer

Upvotes
Accepted
56k 145 45 65

@Bruno.Leal

The TCP port could be 443. I have run it and it can connect to the server.



1605690631672.png (50.2 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.