question

Upvotes
Accepted
48 2 3 7

RFA compatibility with c++17

Hello. Question from a client:

Currently we are using RFA 8.0 for our development but this version is making use of dynamic exception specification which is deprecated in c++17. Is there an RFA library which is compatible with c++17 ?

rfarfa-apic#c++
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Upvote
Accepted
28.3k 30 11 15

Hello @dumitru.arama ,

The language revisions such as C++17 are not explicitly certified against RFA API releases.

Rather, please see API Compatibility Matrix->Compiler tab it's specific compilers are certified as supported, per specific versions of RFA.

RFA at present is feature-complete, fully supported in the latest version.

For the new features support, I would consider to plan to migrate to RTSDK C/C++API suite at a convenient time for the client organization. EMA API is the high level, ease of use API that is part of RTSDK suite. Would like to suggest to review article Migrating from Refinitiv Legacy to Strategic APIs for helpful information and for more details Migrating from the Legacy Robust Foundation API (RFA) to the Enterprise Message API (EMA) on how to plan and proceed the most efficient way.

We would also like to encourage our developer clients to register on developers portal, and to participate in developers forums discussions directly.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.