question

Upvotes
Accepted
1 0 0 1

Redi API not showing positions

I have the Redi API running but it's only showing values for 2 positions and others are giving a Ref error. This is despite the Ref column being a copy paste of ticker format from the Redi portal itself. I have spoken to customer service multiple times they have not been able to resolve this. I have also used the Redi API position monitor file from GitHub but it is giving me a value/type error even though my account numbers are showing up there. Please help!

#technology#productexcelredi-api
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
78.6k 248 52 74

@RajV

First of all, please make sure that the REDI API is installed properly. You can follow steps on the REDI API Quick Start.

After opening the Position Monitor.xlsm file, on the REDIPositions sheet, you will see your account.

Then, click Add button and then click on the account to see positions in that account.

1704253245101.png

If you are unable to get the data, please share the screenshots from Excel and REDI Position Monitor.

1704253482147.png

You may need to check how did you send the order. You may set some properties in the order that causes this issue.

To get the direct response, please contact REDI support team directly via MyRefinitiv.



1704253245101.png (52.3 KiB)
1704253482147.png (19.2 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
78.6k 248 52 74

@RajV

Thank you for reaching out to us.

Are you using the Position Monitor.xlsm example from GitHub?

The results should be similar to the results from the Postion Monitor on REDIPlus.

1704189890705.png



1704189890705.png (37.3 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
1 0 0 1

I am not getting these results with that file. It is showing my account number but when I try to get it to show positions it gives me a "type error" and no results. How do I fix this?

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
1 0 0 1

Is there a way I can email you or message you directly for help with this? Thank you

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.