question

Upvotes
Accepted
1 0 1 1

Unsupported environment in EMA

While trying to compile one of the examples from EMA api (100_Series_Examples/100__MarketPrice__Streaming), it threw an error that the environment is unsupported. Is RED HAT necessary for running EMA or will ubuntu suffice?

elektronrefinitiv-realtimeelektron-sdkrrtema-apielektron-message-apilinuxubunturedhat
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
16.8k 31 9 12

Hello @achyut

The EMA APIs (both C++ and Java editions) are supported and have been tested with the following Linux OS only

  • Oracle Linux 6.0 - 64 bit
  • Oracle Linux 7.0 - 64 bit
  • Red Hat Enterprise Linux 6.X - 64 bit

The other Linux distributions are not guarantee to work and support for the EMA APIs.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
1 0 0 0

i don't need support - I just want it to build it and use the API. Apparently, you can't even do that! Is that correct?

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.