For a deeper look into our Eikon Data API, look into:

Overview |  Quickstart |  Documentation |  Downloads |  Tutorials |  Articles

question

Upvotes
Accepted
104 7 9 13

eikonapir setting without need for API proxy

I'm trying to set my R environment to work without the need for a separate login through the API proxy. I understood the port has been changed so I downloaded a new version of the eikonapir package and installed but it still doesn't work and gives error message below:

Error in get_proxy_port() : no slot of name "proxy_port" for this object of class "RequestInfo"

eikoneikon-data-apipythonworkspaceworkspace-data-apirefinitiv-dataplatform-eikonreikon-data-api-r
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Upvote
Accepted
104 7 9 13

A workaround I found to work after looking at the changes in github is to add the line below after setting the app_id. Would still like to hear from the package owner on the reason for the initial error and if the workaround is the proper way to initialize the package maybe an update to the documentation would be well received by the R users community...

set_proxy_port(9000L)

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Please refer to this question.

The new version is available.

I get a message "access denied" when I click the link.

The thread was marked as private. I just made it public. Try again, you should be able to access it now.

Show more comments