question

Upvotes
Accepted
1 0 1 1

connect to dacs api with dns

when try to connect with DACS API by DNS it is not retrive any data but when try connect with IP it is working fine

elektronrefinitiv-realtimetrepapiDACS
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
9.5k 10 5 7

Hello @ramy.refaat

I understand that you use your application with openDACS API to connect to dacs sink daemon but it fails. Do I understand correctly?

According to OpenDacs - Java Development Guides, at AuthorizationSystem class in setProperty method, the host name of machine running dacs sink daemon can be set as shown below:

I have tried openDACS Java API included in RFA Java 8.1.3.L1 by running DacsSubscribeClient application shipped with Open DACS API - Java Edition - 8.0.0.L1. The application connected to dacs sink daemon using host name(myhost) successfully as shown below:

Hence, the openDACS Java API can work with host name.

It is possible that DNS cannot solve the host name. Please try to telnet to the host name. If telnet fails, please contact the team who takes care of DNS.


icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
1 0 1 1

thanks for your reply but i need to clarify some thing it is working with me when i am trying IP but when i using DNS it is not retrieve any data and also i am using rfa tool to set rssl namespace connection ip

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
9.5k 10 5 7

Hello @ramy.refaat

Have you telnet to the host name and port which your application tries to connect to? It is possible that this is DNS problem e.g. DNS cannot convert the host name into an IP address . Since both RFA application and OpenDACS application can connect to the host by specifying host name.

The problem is the RFA application cannot get data when host name is specified in the RFA configuration. When IP is specified in the configuration, the application can get data. Do I understand correctly?

If you use RFA Java application and you can telnet to host name and port successfully, please share the RFA Java trace log file. Then, I can investigate the problem further.

To enable RFA Java trace log file, please set ipcTraceFlags = 7,mountTrace=true and specify logFileName parameter of the connection node like an example below:



icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hello @ramy.refaat

Do you still face the problem?

If yes, please share me RFA Java trace log file.