question

Upvotes
Accepted
3 0 3 3

Implement JSON in Elektron API

Hello everyone,

I'm trying implement an JSON parse in EMA API, but I'm stuck in this Error:

error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options.

I'm using this library: https://github.com/nlohmann/json

How must I do to overcome this issue? Do you have any suggestion of library compatible with EMA API?

Environment:

- Oracle Linux Server 7.8

- g++ (GCC) 4.8.5 20150623 (Red Hat 4.8.5-39.0.3)

elektronrefinitiv-realtimeelektron-sdkrrtema-apielektron-message-apijson
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Upvotes
Accepted
12k 59 39 61

Hi @Bruno.Pereira,

Looking at your error, it's not clear that there is an issue with EMA but rather JSON library. Did you try compiling a simple JSON application without EMA? And also a simple EMA application without JSON? I just want to make sure this error appears when you try to combine the 2 libraries into your application.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.