For a deeper look into our Eikon Data API, look into:

Overview |  Quickstart |  Documentation |  Downloads |  Tutorials |  Articles

question

Upvotes
Accepted
1 0 1 0

"API Proxy is not available"

Hello,

I'm unable to use the R API since the beginning of this week. I'm getting below error message. I have used it before and I am able to use it on a company desktop computer. It stopped working on my company notebook however.

- Reinstalled Eikon and R Packages
- Tried with/without VPN
- Checked Eikon running, logged in to Datastream etc.

Error:

[1] "Response *************************************"
[1] "API Proxy is not available"
[1] "Response status *************************************"
[1] 503

Note: The same code was working on this machine and it is working on another (desktop) machine.

eikoneikon-data-apipythonworkspaceworkspace-data-apirefinitiv-dataplatform-eikoneikon-data-api-rerror-503
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvote
Accepted
28.3k 30 11 15

Hello @dominik.hoffmann,

Understood.

Does the problem continue to manifest for you? If it does, we would like to help. @wasin.waeosri has suggested an easy way, using python, to confirm your version of eikon libraries installed.

In my understanding, installing python (I would install version 3.7) would help, by enabling you to perform standard troubleshooting steps, and figure out why API proxy is not listening. Without proxy listening, neither Python nor R will be able to connect to it.

Once your environment is confirmed to be working, you would continue coding in R.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
45.2k 103 44 60

@dominik.hoffmann

You can refer to 3. Verify that Eikon Desktop is running properly and APIPROXY service is enabled in this Eikon Data API(Python) Troubleshooting article.

Please verify that the APIPROXY is running.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
1 0 1 0

All done but problem still there.

Log file:
[2020-09-14 08:17:34.213|1|api-svc|1|INFO] PO: SIDEBYSIDE,APIPROXY
[2020-09-14 08:17:34.216|1|api-svc|3|DEBUG] create SIDEBYSIDE
[2020-09-14 08:17:34.220|1|api-svc|3|DEBUG] create APIPROXY


and

[2020-09-14 08:17:34.775|1|api-svc|1|INFO] Listening to port=9000

Port in Use: 9000

http://localhost:9000/ping?all:


{"port":9000,"mode":"eikon4","pid":23700,"hasSecure":true,"startedTime":"Mon Sep 14 2020 10:17:34 GMT+0200 (W. Europe Daylight Time)","subApps":[{"path":"/heap"},{"path":"/ping"},{"path":"/sxs","data":{"hasSecure":true,"sxsApps":{}}},{"path":"/api"}]}




icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
14.3k 23 8 12

Hello @dominik.hoffmann

Which version of Eikon Data API that you are using? You can use the following code to verify the version

import eikon as ek
ek.__version__

Could you please test with Eikon Data API version 1.1.6? The answers conversations in this post and this post might help you.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
1 0 1 0

I am using the R API, as stated above. That looks like a Phyton code.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.