question

Upvotes
Accepted
58 5 10 10

Why the connection disconnected at 10:46 yesterday?

Normally, it will reconnect using emaj as shown in the follwing capture.

However, I don't know what happened yesterday. There is no logs, it just can't receive data(Foreign exchange).

elektronrefinitiv-realtimeelektron-sdkrrtema-apielektron-message-apiconnection
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Upvotes
Accepted
9.6k 10 6 7

Hello @Raj.Huang

The error “Network is unreachable: no further information” seemed that there was a network problem at that time. The problem made EMA application could not connect to the server so the server could not send data to the application. I suggest you should contact your company’s network team to investigate the network between the application to the server.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Thanks for your answer. I know the error 'Network is uncreachabke....', that is the normal error, I did it intentionlly. But at 10:46 yesterday, there are no logs like that. And it didn't reconnect itself, it just no data antmore util I restart my application.

Hello @Raj.Huang

I suggest you set XmlTraceToStdout to 1 in EmaConfig.xml located in the application’s run directory. For example:

<Consumer>
  <Name value="Consumer_1"/>
  ...
  <XmlTraceToStdout value="1"/>
</Consumer>

This will enable EMA traces its messages (received and sent messages) in XML format to stdout. When the problem occurs again, we can check in the log messages what happens.

If you enable it successfully, you should see a refresh message sent from the server that EMA traces. For example:

Show more comments