question

Upvotes
Accepted
7 3 2 5

[EMA Java] Sometimes Receiving (blank data)

Once in a while, I am receiving (blank data) for specific fields (instead of the field not being sent). Is this a normal situation? Seems to always have DSPLY_NAME=Rmtes.

Ex:

FieldEntry fid="22" name="BID" dataType="Real" value="(blank data)"

elektronrefinitiv-realtimeelektron-sdkrrtema-apielektron-message-apidataforex
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hello @andre.malenfant

Thank you for your participation in the forum.
Is the reply below satisfactory in resolving your query? If yes please click the 'Accept' text next to the reply. This will guide all community members who have a similar question. Otherwise please post again offering further insight into your question.

Thanks, -AHS

1 Answer

Upvotes
Accepted
25k 87 11 23

Hi @andre.malenfant

There are valid reasons for receiving a blank field - indicating that there is no current value for that field and any existing value you have (for that field) should be removed from any application level representation you have for that instrument e.g. during close run as described in this post.

If, however, you believe the blank field to be incorrect, then you should raise a query with out Content helpdesk who can confirm if the blank field value is correct or an error. You should create a 'CONTENT' type ticket and select 'I believe content is incorrect or incomplete' as the sub type.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.