For a deeper look into our World Check One API, look into:

Overview |  Quickstart |  Documentation |  Downloads

question

Upvotes
Accepted
11 2 3 2

World Check One - API - Pilot Account

Last 4 months world check one API {pilot account} was working fine. Suddenly it is not returning any simple search also via API.

Product: World Check One API [Pilot Account] When I hit the world check screening request api from my postman, I get the response as { "results": [] }. While as the same name gets me a different response on the world check UI. This is Schroders Pilot account. We are in development phase using the worldcheck one API with Pega Systems. Last 4 months this was working fine. Recently started showing this issue. Is this require any reset ? Is it pilot account reached the maximum ? Please help us to solve the problem asap.

Pilot accounts are capped at 1,000 screening cases. I think Account may be reached this limit. How to reset the same ?

I am not able to find anything relevant in developers forum. If I search HSBC via API, I'm not getting any result. 200. OK is the result. But no response data. But If I search using the old Case System Id [which is 2 months old], then I am getting response in the Postman. WC UI is giving result for HSBC, but API is giving blank response []. { {protocol}}{ {gateway-host}}{ {gateway-url}}cases/{ {case-system-id}}/results

world-checkworld-check-oneerrorpilot-environmentresponse
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
11 2 3 2
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
4.5k 4 7 8

@athomas,

Can you please confirm if you have made any changes in the account setting of your pilot account where you are seeing this behavior?

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
11 2 3 2

@Prabhjyot.Mandla - No changes.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
11 2 3 2

CaseSystemId - 5nzbfqankw2o1fawmd8ad3q6m [Axis Bank] Screenshot attached.

@Prabhjyot.Mandla - No changes made. Suddenly stopped working


ca67f580.png (39.8 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
4.5k 4 7 8

@athomas,

Can you please share the payload which was used for screening?

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
11 2 3 2

@Prabhjyot.Mandla - Today I have tried for the same case system id and got the results. Data is updated after 10 hrs. Normally we use to get within 1 minute. Via Pega also normally wait for 1 minute to receive the screening match result and proceed. All the previous case system id also return result after 10 hrs. Any idea what is changed and how to fix this issue. Please help us to resolve the issue asap. Thanks. CaseSystemId - 5nzbfqankw2o1fawmd8ad3q6m [Axis Bank] SEQ-case-investigate-case-details: Fetch full case details

"creationDate": "2021-01-06T13:48:07.428Z",

"modificationDate": "2021-01-06T22:46:20.975Z", SEQ-case-investigate-results: Get screening results - All the record dates are below.

"creationDate": "2021-01-06T22:46:20.975Z",

"modificationDate": "2021-01-06T22:46:20.975Z",

This is the same behavior with last few case system ids.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

@athomas,

Please refer to the information provided in the following link. -

https://community.developers.refinitiv.com/questions/71446/intermitent-issues-on-pilot.html