question

Upvotes
Accepted
29 2 2 2

Could not read IPC Mount Ack

Trying to connect to TRCC. Account/credentials work, but sometimes I get 'Error: 1002 Could not read IPC Mount Ack. Connection attempt has failed.'

What is the problem?

elektronrefinitiv-realtimeelektron-sdkrrtema-apircc
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
15.2k 28 8 12

Hello @efreeman

This issue seems to be the connection issue between the API and RCC server. I suggest you contact the RCC support team via the https://my.refinitiv.com/ website to help you verify the disconnection. You may need to give them a specific date and time that the issue occurred.

You can submit a ticket to the RCC support team via the https://my.refinitiv.com/content/mytr/en/helpandsupport.html link and choose the "Refinitiv Contribution Channel" product.

rcc-myrefinitiv.png

If you want to verify on the API side, the EMA log/trace file is mandatory. You can enable the EMA C++ log file via the EmaConfig.xml configuration file. Please see more detail on the "EMA C++ Logging" and "XML Trace" sections of the Enterprise Message API (EMA) - Configuration Overview article.


rcc-myrefinitiv.png (12.6 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
15.2k 28 8 12

Hello @efreeman

Could you please give us more detail about the application and the issue?

  • Are you using EMA Java or EMA C++, and what is the version of the API?
  • Does it happen randomly or always at a specific time?
  • When the problem occurs, can the API recovery the connection?
  • What is the endpoint that you are connecting to?
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
29 2 2 2

Hi,

I am using EMA C++. This occurred when I was testing and it eventually went away. I was not sure if I was doing something wrong or not. I was looking for a reason why I would get such an error, in general, and not for just this one specific instance.

Regards

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.