question

Upvotes
Accepted
11 2 3 4

Pandas.np depreciation warning

Hi. I am getting the following warning and wanted to bring it your attention. Will this be fixed in future iterations of the API?


/Library/Python/3.7/site-packages/eikon/time_series.py:209: FutureWarning:=

The pandas.np module is deprecated and will be removed from pandas in a future version. Import numpy directly instead

eikon-data-apirdp-apirefinitiv-data-platformrefinitiv-data-platform-librariespandasdeprecatednumpy
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvote
Accepted
23.6k 84 10 22

Hi @michaelberk99 and @JIAN.DU

I have been advised by the developers that this issue will be resolved in future releases of the RDP library and the Eikon Data API.

Indeed the alpha version 1.1.3a0 of the Python Eikon Data API already has this issue fixed. I do not recommend using the Alpha version for any production implementations.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hi Umer - thank you for your reply. I see you mentioned the eikon library, however I was referring to https://pypi.org/project/refinitiv-dataplatform/#description.

Would you happen to know when this will be applied to the library?

Hi @JIAN.DU

Indeed the same changes are being applied to the RDP library as well - in time RDP library and Eikon library will be the one library.

I can confirm that I am using an internal test RDP version and the pandas warning no longer exists.

I have not yet upgraded to the latest test version - but as its a later version it should also include this fix - https://test.pypi.org/project/refinitiv-dataplatform/

NOTE: If you do decide to try the test version, I would not recommend using it for any current production/critical usage until you have tested and satisfied yourself it is stable enough.

Upvotes
14.7k 39 12 18

@michaelberk99, What version of Eikon module are you running. I have the latest version, and don't numpy imported as such or get this error on get_timeseries API call.


>>> ek.__version__
'1.1.2'
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
39 3 6 5

The RDP APIs refinitiv.dataplatform library - 1.0.0a0 (https://pypi.org/project/refinitiv-dataplatform/#description) currently have this warning. Is the RDP library on Github or similar? Happy to help.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
14.7k 39 12 18

You will have to be more specific - The error message in your original post is showing Eikon Data API, but the link is to RDP library. Both of which are different products.

Can you please show how I can replicate this error message - the code snippet etc. Also what is your Eikon and RDP library version number?

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

In my case, I am referring to refinitiv.dataplatform (RDP library, not Eikon), but the underlying issue is the same. My RDP library is above, the latest on pip. There are references to pandas.np, whereby should import numpy directly.


You will get the warning when you import the (RDP) library.

Upvotes
14.7k 39 12 18

Thanks for the information, but I am still unable to reproduce your error. Can you point to the actual file within the package which imports numpy from pandas.

(rdp) C> pip list | grep -i refinitiv
refinitiv-dataplatform 1.0.0a0

(rdp) C> python
Python 3.6.2 |Continuum Analytics, Inc.| (default, Jul 20 2017, 12:30:02) [MSC v.1900 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>>
>>> import refinitiv.dataplatform as rdp
>>>
>>> rdp.__version__
'1.0.0-alpha'
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvote
39 3 6 5
>>> import refinitiv.dataplatform <path>\lib\site-packages\refinitiv\dataplatform\pricing\pricing_.py:8: FutureWarning: The pandas.np module is deprecated and will be removed from pandas in a future version. Import numpy directly instead from pandas import np
>>> refinitiv.dataplatform.__version__ '1.0.0-alpha'


I am on pandas 1.0.3.

numpy==1.18.2

pandas==1.0.3


Depreciating pandas.np and pandas.datetime, is intentional. (see: https://github.com/pandas-dev/pandas/issues/30296 ) I think the warnings are from 1.0.x onwards from start of this year.


There are numerous functions still referencing pandas.np


So while the RDP library works (just shows warning) it is recommended to update and import numpy explicitly for future compatibility.


pandasnp.png (53.0 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
14.7k 39 12 18

Thanks, I will pass this information to the developers.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Any update to this please?

Hello,

I'm getting this message as well from the Eikon API version 1.1.2. Is there a projected date for an API update resolving the deprecation issue?

Thank you!