For a deeper look into our DataScope Select REST API, look into:

Overview |  Quickstart |  Documentation |  Downloads |  Tutorials

question

Upvotes
Accepted
1 0 5 2

Data Scope java request for Spread Ric - Time Series

Hi all,

Sorry in advance if this question not must be included in this forum.

We have done a little java program based on the rest api tutorial for data scope that obtain the time series of some rics.

In November 2017 we requested "Universal Close Price" and "Latest Trade Yield" for the rics: AAAGBPAGE10Y= and AAAGBPSUP3M=. We always get some of these prices for the two selected rics.

Now we only get one of the two values for the ric AAAGBPSUP3M= but not for the AAAGBPAGE10Y=.

We do this directly through the data scope interface (instead of doing the request from java) and we obtain one of the two values for the two rics.

We have tried to add the "Close Price" in the request that we do using the java program and now I obtain value for both rics.

We would only like to know if we are doing the request correctly to explain why before we obtained one of the two price ("Universal Close Price" or/and "Latest Trade Yield") for the ric AAAGBPAGE10Y= and now not. And yet this happens for the ric AAAGBPSUP3M=.

This is our request:

JSONOrderedObject tsExtractJSONObject = new JSONOrderedObject() .put("ExtractionRequest", new JSONOrderedObject() .put("@odata.type", "#ThomsonReuters.Dss.Api.Extractions.ExtractionRequests.TimeSeriesExtractionRequest") .put("ContentFieldNames", paramJSONArray) .put("IdentifierList", new JSONOrderedObject() .put("@odata.type", "#ThomsonReuters.Dss.Api.Extractions.ExtractionRequests.InstrumentIdentifierList") .put("InstrumentIdentifiers", ricJSONArray) .put("ValidationOptions", JSONObject.NULL) .put("UseUserPreferencesForValidationOptions", false)) .put("Condition", new JSONOrderedObject() .put( "LastPriceOnly", false ) .put( "StartDate", startDateString ) .put( "EndDate", endDateString ) .put( "LookBackPeriod", "EOD-4M")));

startDateString = startDateString

endDateString = 2018-01-16T00:00:00.000Z

paramJSONArray = ["Instrument ID","Instrument ID Type","RIC","Trade Date","Yield","Universal Close Price","Latest Trade Yield","User Defined Identifier","Close Price"]

ricJSONArray = [{"Identifier":"AAAGBPAGE10Y=","IdentifierType":"Ric"},{"Identifier":"AAAGBPSUP3M=","IdentifierType":"Ric"}]

Many thanks in advance,

Elisa

dss-rest-apidssdatascope-selectjavatime-seriesspread
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Upvotes
Accepted
56k 145 45 65

I got the same result as yours. It could be a content issue.

Please submit this question to DSS support team to investigate the issue. You can raise a new case to DSS support team via Contact Us.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.