question

Upvotes
Accepted
5 0 2 5

UPA NIProvider channelInactive portno=<[channel failure] socket channel is not in the active state for getBuffer>.

We have a NIprovider application that provide Market by voulume. For some reason, we received a channel failure, exact error message below.

[ChannelSession]channelInactive portno=49504<[channel failure] socket channel is not in the active state for getBuffer>.

Any idea what could cause the issue?

version:

productVersion: upaj7.4.0.L1.all.rrg

productInternalVersion: upaj7.4.F9

productDate: Fri May 16 12:00:00 CST 2014 Thomson Reuters

elektronelektron-sdkrrteta-apielektron-transport-apipricingnon-interactive-providerchannel
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Upvotes
Accepted
56k 145 45 65

@mreina

If the application calls the Channel.getBuffer method on the inactive channel, UPA will return the null buffer with this error.

It is possible that the connection between the application and ADH has been lost. You may need to verify the ADH log for disconnection.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Because we are using a Private Stream to pricing into the Reuters Electronic Trading software, where should we look to identify the cause of the disconnection? We have no ADH that our NIProvider connects to...

It should be the server that the UPA NIProvider is connecting to.