question

Upvotes
Accepted
4 1 0 2

C++ StarterConsumer crashed before connect.

Hi,
I'm a newbie, currently I tried to compile and run StarterConsumer example application with MSVC 2017. I already installed EZD 1.3. But then when I ran the application, I got the following error:

RFA Internal failure

Application: StarterConsumer
Process Id: 0xEA8
Thread Id: 0x3BA4

File: D:\Jenkins\workspace\RFACPPDEV_RCDEV\OS\VS150-32\rcdev\source\rfaut\Common\Support\Util\Impl\JIT_Support.cpp
Line: 133

Problem:
	The specified module could not be found.

	RFA_VERIFY( 0 ) failed

Stack Trace:
0x55B88F44  E:\Developments\Reuters\Delphi_Reuters\Wrapper\Lib\Lib\Examples\StarterConsumer\Debug_WIN_32_VS150_Shared\RFA8_SessionLayer150.dll: getGlobalEventNotifier() + 18500 bytes
0x55B8A8C6  E:\Developments\Reuters\Delphi_Reuters\Wrapper\Lib\Lib\Examples\StarterConsumer\Debug_WIN_32_VS150_Shared\RFA8_SessionLayer150.dll: getGlobalEventNotifier() + 25030 bytes
0x55B8CBE3  E:\Developments\Reuters\Delphi_Reuters\Wrapper\Lib\Lib\Examples\StarterConsumer\Debug_WIN_32_VS150_Shared\RFA8_SessionLayer150.dll: getGlobalEventNotifier() + 34019 bytes
0x55B753F1  E:\Developments\Reuters\Delphi_Reuters\Wrapper\Lib\Lib\Examples\StarterConsumer\Debug_WIN_32_VS150_Shared\RFA8_SessionLayer150.dll: rfa::sessionLayer::Session::~Session() + 8145 bytes
0x00DE886A  E:\Developments\Reuters\Delphi_Reuters\Wrapper\Lib\Lib\Examples\StarterConsumer\Debug_WIN_32_VS150_Shared\StarterConsumer.exe: StarterConsumer::init() + 1530 bytes
           e:\developments\reuters\delphi_reuters\wrapper\lib\lib\examples\starterconsumer\starterconsumer.cpp, line 150
0x00DEBC46  E:\Developments\Reuters\Delphi_Reuters\Wrapper\Lib\Lib\Examples\StarterConsumer\Debug_WIN_32_VS150_Shared\StarterConsumer.exe: main() + 102 bytes
           e:\developments\reuters\delphi_reuters\wrapper\lib\lib\examples\starterconsumer\starterconsumer.cpp, line 63
0x00DF73DE  E:\Developments\Reuters\Delphi_Reuters\Wrapper\Lib\Lib\Examples\StarterConsumer\Debug_WIN_32_VS150_Shared\StarterConsumer.exe: invoke_main() + 30 bytes
           d:\agent\_work\3\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl, line 78
0x00DF72F7  E:\Developments\Reuters\Delphi_Reuters\Wrapper\Lib\Lib\Examples\StarterConsumer\Debug_WIN_32_VS150_Shared\StarterConsumer.exe: __scrt_common_main_seh() + 343 bytes
           d:\agent\_work\3\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl, line 288
0x00DF719D  E:\Developments\Reuters\Delphi_Reuters\Wrapper\Lib\Lib\Examples\StarterConsumer\Debug_WIN_32_VS150_Shared\StarterConsumer.exe: __scrt_common_main() + 13 bytes
           d:\agent\_work\3\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl, line 331
0x00DF7448  E:\Developments\Reuters\Delphi_Reuters\Wrapper\Lib\Lib\Examples\StarterConsumer\Debug_WIN_32_VS150_Shared\StarterConsumer.exe: mainCRTStartup() + 8 bytes
           d:\agent\_work\3\s\src\vctools\crt\vcstartup\src\startup\exe_main.cpp, line 17
0x74946359  C:\WINDOWS\System32\KERNEL32.DLL: BaseThreadInitThunk() + 25 bytes
0x76FC7A94  C:\WINDOWS\SYSTEM32\ntdll.dll: RtlGetAppContainerNamedObjectPath() + 228 bytes
0x76FC7A64  C:\WINDOWS\SYSTEM32\ntdll.dll: RtlGetAppContainerNamedObjectPath() + 180 bytes



Is there someone that can help me with this error?

Thanks.

treprfarfa-apic++windows-10jit
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvote
Accepted
7.6k 15 6 9

@danny.kurniawan

It looks like you did not copy required RFA DLL file such as RFA8_SessionLayer_OMM150.dll to the running directory. I would suggest you copy all DLL files from directory "<RFA Installed Path>\Libs\WIN_32_VS150\Release_MD" to the same folder as your StarterConsumer.exe. Also, you should copy .pdb file to the same folder so that when it has an error, you can see more details from the call stack.

And don't forget to copy dictionary files from "<RFA Installed Path>\etc\RDM", otherwise the application can't find dictionary files.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
4 1 0 2
@moragodkrit

You made my day!

Thank you very much. I didn't notice that I didn't copy all of the DLLs. I was so stupid that I just added DLLs that reported missing by Windows only.
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.