question

Upvotes
Accepted
98 17 29 27

Error 404 using SxS API.

I'm doing the setup proposed in here.


I'm trying to send a PING, having Eikon Desktop running but the request seems to fail.


Any idea why that might be happening?




eikonside-by-side-apipostman
1587931874342.png (37.3 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Upvotes
Accepted
39.3k 76 11 27

The port number is wrong. In your screenshot you're sending the request on port 8088. Eikon API Proxy, which handles SxS requests, listens on port 9000.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Yes you are right, but the tutorial says we can use another if 9000 is in use.

Checking again, the alternatives must go incrementally. I get it that 8088 does not meet that criteria, but I attempted a couple of others to no avail unfortunately (9000 up to 9005). The results for these weren't even the 404 error, it was this (in the snapshot):

1587941938037.png (124.9 KiB)

On startup Eikon API Proxy attempts to occupy port 9000. If port 9000 is already occupied by another application, then Eikon API Proxy tries port 9001. If port 9001 is not available either, then it tries port 9002 and so on until it finds a port that is available. Then Eikon API Proxy starts listening on this port and on this port only until Eikon is closed. To connect to Eikon API Proxy you must use the port it is listening on. To troubleshoot why you're not getting any response, enable SxS log as described on this thread.

https://community.developers.refinitiv.com/questions/26052/httperror.html