question

Upvotes
Accepted
1 0 0 4

RFA7.2 failed to connect RMDS in different linux environment

Currently, we are migrating our RFA7.2 based program from windows to Linux,but in development environment,everything is ok,but when I deploy the project to the ST environment,it failed to connect RMDS,I compare and the only difference is the /etc/hosts file,but I have no permissions to amend the hosts file in ST,the connection issue as below:

Received CONNECTION_EVENT: myNamespace::SLLConnection
{ state: DOWN, code: NONE, text: "Not connected: com.reuters.mainloop.DispatchException: Could not determine position"}

Any suggestion for us to debug?

Thank you very much for any reply.

linux
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
14.3k 23 8 12

@shishuoxinyux

I can replicate the problem in my environment. My /etc/hosts file is

127.0.0.1 apis11 localhost localhost.localdomain localhost4 localhost4.localdomain4

::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

I can replicate the problem by commenting the first line (the 127.0.0.1 line), then use the MDSubDemo example to subscribe data to ADS server (non DACS). Can you share us your /etc/hosts file? The hosts file should contain 127.0.0.1 line by default.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
7.6k 15 6 9

@shishuoxinyux

Do you have the error message when it failed?

We have user found connection issue when using RFAJ connect RMDS in linux environment. not sure is this the same one?
RFA7.2 failed to connect RDMS in Linux 6.4

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

@moragodkrit
it's the same problem,and I follow the reply from that question,it's ok in our development environment ,but when I change the environment ,the same problem has happened again,but I'm not sure if is the problem of the hosts file.

Upvotes
1.5k 3 5 7

Still using SSL interface, eh?

I don't know how your application is doing its configuration but in a standard RFAJ SSL application (MarketData interface) you would - as I remember - be able to force the position into something you feel is correct, rather than letting the API decide the position for you .. which it obviously fails at.

So, according to Config Guide (legacy), you would need to define username explicitly as in

username=john+256+10.1.5.231/myhost

In this example "10.1.5.231/myhost" becomes the position.

Note that an application force setting the position part of the DACS login should be an exception and I wouldn't recommend it for production unless you know exactly what you are doing.

Best of luck.

Lars

Addicticks

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.