question

Upvotes
Accepted
1 0 0 1

DACS connection not working from AWS

I am moving some old rfa java code from on prem to AWS. When trying to run from aws I am getting the error. Network connection to DACS Multiplexer down. My assumption is that the firewall is blocking communication with the DACS server. What port would I need to open to communicate with the DACS server and can I disable communicating with DACS and just let the ADS server do the authentication? If so how?

rfajavaDACSaws
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Upvotes
Accepted
53k 137 44 63

@ssweeney

According to the error message, you need to run a DACS sink daemon on the machine.

The followings are TCP ports used by the DACS sink daemon.

tcp        0      0 0.0.0.0:dacs_lib        0.0.0.0:*               LISTEN      29743/dacs.snkd
tcp        0      0 0.0.0.0:8261            0.0.0.0:*               LISTEN      29743/dacs.snkd
tcp        0      0 replablinux1:59490      192.168.27.67:dacs_perm ESTABLISHED 29743/dacs.snkd

The service file contains the following entries.

dacs_lib        8211/tcp        dacs_adm
dacs_perm       8250/tcp
dacs_snkdstat  8261/tcp

You need to contact the DACS support team directly via MyRefinitiv to confirm TCP ports used by a DACS sink daemon to connect to a DACS server.

However, you can disable DACS checking in the RFA API. Please refer to the answer on this thread.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.