question

Upvotes
Accepted
3 0 0 1

Refinitiv Data Platform Library (Typescript) timeout

Hi all,

I am trying to Get multiple fields for multiple instruments and I have only got a 10second window as there is a default 10 seconds timeout error when it takes too long for the API to give me a response.

Is there any way for me to set the timeout to a longer timeframe like 30 seconds?

Thanks,

#technologyrefinitiv-data-platform-librariestypescript
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
78.6k 248 52 74

@tristan.lee

It should read the configuration file located in the current directory.

I tested it with the example on GitHub.

1696569209282.png

You can enable the debug log level to check the value of request-timeout.

{
    "http":{
        "request-timeout": 60
    },
    "logs": {
        "level": "debug",
        "filter": "*",
        "transports": {
            "console": {
                "enabled": true
            },
            "file": {
                "enabled": false,
                "name": "rdlib"
            }
        }
    }
}



1696569209282.png (88.4 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
24.6k 54 17 14

Hello @tristan.lee

Could you please share your snippet code that encounters the problem, and the following information as well?

  • The Library version
  • Which session type that you are using? I am assuming you are using the Platform session, am I correct?
  • Full logs when the problem occurs.
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Thanks For replying @wasin.w ,


1. I have this version on my package.json file ==>

"@refinitiv-data/data": "^3.11.0-beta"

2. I am using platform session yes.

3. Its just a timeout error of 10000 ms exceeded.

Thanks
Tristan



Upvotes
78.6k 248 52 74

@tristan.lee

Is it http request-timeout? The default value is 10 seconds.

[2023-10-04T03:11:56.676Z][DEBUG][http:client][55356] HTTP settings: { 'request-timeout': 10 }

You can change its value via the following configuration.

{
    "http":{
        "request-timeout": 60
    },
    "logs": {
        "level": "debug",
        "filter": "*",
...


[2023-10-04T03:13:16.372Z][DEBUG][http:client][133832] HTTP settings: { 'request-timeout': 60 }
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

THanks for replying @Jirapongse,

Please have a look at my rdplibconfig.prod.json file

{

"http": {

"request-timeout": 60

},

"logs": {

"level": "warn",

"filter": "*",

"transports": {

"console": {

"enabled": false

},

"file": {

"enabled": false,

"name": "rdlib"

}

}

}

}

I am struggling to find where I should import the rdplibconfig file as it seems to still send the request with 10 seconds timeout.

I am sending a post request this way:


const params: EndpointRequestDefinitionParams = {

url: 'data/datagrid/beta1/',

bodyParameters: {

'universe': HomecodeArray,

'fields': fieldsArray,

},

method: Delivery.EndpointRequest.Method.POST,

};

const def = Delivery.EndpointRequest.Definition(params);

const response: any = await def.getData(session);


Thanks for you help!
Tristan

Upvotes
3 0 0 1

Thank you so much @Jirapongse !

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.