question

Upvotes
Accepted
1 0 0 0

RTC - NIP

Hi,


I configured RTC for a posting cache and NIProvider service as described below


!!! RSSL

*rtc*enableRsslServer : True

*rtc*rsslServerPort : 14005


!!! Non-interactive Cache for posting

*rtc*cacheServiceList : <source>

*rtc*<source>*cacheLocation : srcApp

*rtc*<source>*cacheType : sourceDriven


and then try to publish with following:


./testserver -S <source> -pb 1000 -f NIPsample_performance.xml -c -N 14005


The source is going up and if i dump incoming i can also see that there is data.


However if i test with "example" or testclient


./testclient -S <source> -il GOOG.OQ -u radmin -v -md 6 -X d 3


I am getting: Not in Cache


DSPLY_NAME : STRING 12 : [Not In Cache]

Image Received. RespFlags<0x1e8> FragCount<0> PendQ Count<0000> PendOutQ Count<0001> GroupId<7>:<GOOG.OQ>:<6>


Any idea what i still missed? Please advice.


#productcaching
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
26.3k 60 17 14

Hello @EdwardN

I checked your configuration and found this:

*rtc*<source>*cacheLocation : srcApp

Based on the ADS Pop (another name of RTC server) configuration file, if you want that server to cache data, the cacheLocation should be set to ssl as follows:

! *ads*${svc}*cacheLocation : ssl
!#help
!    cacheLocation: { ssl, srcApp }
!
!    Inidicates where the data cache will be maintained.
!    ssl    - The data cache will be maintained in the ads.
!    srcApp - The data cache will be maintained in the source application,
!              i.e, the ads will not cache data.
!
!    Note: Setting this parameter to srcApp has no affect on aggregated
!    services. To disable caching, use domainsCached and domainsNotCached.
!
!    Default value: ssl
!#end


If cacheLocation: ssl configuration does not help. I strongly suggest you contact the ADS support team directly. You can contact the team via https://my.refinitiv.com/content/mytr/en/productsupport.html website with the "Refinitiv Real-Time Advanced Distribution Server" product (so the helpdesk should redirect you to the ADS team, not back to this Q&A forum).

1705394319033.png




1705394319033.png (27.0 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Thanks, i set the cache location to ssl but still the same. Anyway thanks for your quick respons, i will go back and try as suggested.
Upvotes
82.3k 277 53 77

@EdwardN

Thank you for reaching out to us.

As this forum is more for programming type queries, rather than infrastructure (RTC) queries - I would recommend you raise a 'I need help using the product' ticket with our helpdesk. That way a product specialist can work closely with you and verify the settings.


icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Thanks, unfortunately there is where i started my question. But the helpdesk is also not getting any further so they suggested to also try it here as we are looking to publish from a third party application. However before doing that i tried to get the configuration working first with the standard tools.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.