question

Upvotes
Accepted
20 4 3 6

TRTH RIC Identifiers

When I load the following instrument list into the Reuters Datascope GUI, I can extract all the instruments, but when I use the API I am missing the EDU7-Z7 contract data. Any ideas on why this is happening?

RIC,EDZ7

RIC,EDU7

RIC,EDU7-Z7

tick-history-rest-apirics
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
76.6k 238 52 72
@helen.ristov

Please set "AllowHistoricalInstruments" to true in the ValidationOptions in InstrumentIdentifierList.

"@odata.type": "#ThomsonReuters.Dss.Api.Extractions.ExtractionRequests.InstrumentIdentifierList",    
        "ValidationOptions":{  
            "AllowHistoricalInstruments":true
         },

For example:

{
  "ExtractionRequest": {
    "@odata.type": "#ThomsonReuters.Dss.Api.Extractions.ExtractionRequests.TickHistoryTimeAndSalesExtractionRequest",
    "ContentFieldNames": [
"Quote - Ask Price",
"Quote - Ask Size",
"Quote - Bid Price",
"Quote - Bid Size",
"Trade - Ask Price",
"Trade - Ask Size",
"Trade - Ask Yield",
"Trade - Bid Price",
"Trade - Bid Size",
    ],
    "IdentifierList": {
      "@odata.type": "#ThomsonReuters.Dss.Api.Extractions.ExtractionRequests.InstrumentIdentifierList",         
        "ValidationOptions":{  
            "AllowHistoricalInstruments":true
         },
      "InstrumentIdentifiers": [{
        "Identifier": "EDZ7",
        "IdentifierType": "Ric"
      },{
        "Identifier": "EDU7",
        "IdentifierType": "Ric"
      },{
        "Identifier": "EDU7-Z7",
        "IdentifierType": "Ric"
      }]
      
    },
    "Condition": {
      "MessageTimeStampIn": "LocalExchangeTime",
      "ApplyCorrectionsAndCancellations": false,
      "ReportDateRangeType": "Range",
      "QueryStartDate": "2017-07-18T00:00:00.000Z",
      "QueryEndDate": "2017-07-18T12:00:00.000Z",
      "DisplaySourceRIC": true
    }
  }
}
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
20 4 3 6

Thanks @jirapongse.phuriphanvichai I changed the instrument options and got all the instruments.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.