Upgrade from Eikon -> Workspace. Learn about programming differences.

For a deeper look into our Eikon Data API, look into:

Overview |  Quickstart |  Documentation |  Downloads |  Tutorials |  Articles

question

Upvotes
Accepted
3 0 0 2

Data API Proxy "unavailable"

Sent here by the Refinitiv Workspace support team.

This is the problem:

  • I am running Workspace Desktop version 1.23.269 on macOS 14.1.1.
  • I have generated an "Eikon Data API" and can use it successfully with refinitiv.data in the CODEBOOK app inside Workspace.
  • In any local Python environment (i.e. outside of Workspace), I cannot open a session. I use the exact same code as in CODEBOOK. I tried different Python versions.
  • The status of the "Data API Proxy" is "Unavailable". I have tried to ping localhost:9000/api/status according to the suggestions here, to no avail.
  • I have reinstalled Workspace Desktop, restarted my system, generated a new "Eikon Data API" key, all to no avail.
  • My conclusion: This is a Workspace problem, as the Data API Proxy is not running. The Workspace support team claims this is a dev problem, since I can open a session with refinitiv.data in CODEBOOK.

Can you please help me?

eikon-data-apiworkspaceworkspace-data-api#technology#product
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
16.6k 79 39 63

Hi @markus01,

Given the "Data API Proxy" shows the red "Unavailable" status, that may be the issue. Because of this, it may be the case that your Proxy isn't running and thus the library is simply reacting to this state. I think the first thing to do is make sure your Workspace environment is operating correcting.

Within Workspace, you can access the "Help & Support" link within the menu (top right - question mark logo). In there, you can access the "Contact Us" details and they can help you through the issues you are seeing within the Workspace setup.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hi @nick.zincone ,

Thank you for your thoughts, appreciate your help. I have re-raised the issue with them through the chat.

Upvotes
16.6k 79 39 63

Hi @markus01,

It's possible the data proxy is not running on port 9000. Based on availability, the Workspace Desktop will determine the port and is written to a file called: .portInUse. You can enable console logs to determine which port the library is connecting to.

Before opening the session, do the following:

# Enable logging
rd.get_config()["logs.level"] = "debug"
rd.get_config()["logs.transports.console.enabled"] = True

This will provide more details. The library does pull out the value within the .portInUse so there may be another issue. If you haven't already, I would suggest you restart Workspace. We can also try to manually remove the .portInUse file (It will be re-created when you launch the Workspace application). We can try these steps later - but let's try to better understand your situation based on the logs.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hi @nick.zincone,

Thank you for your reply and suggestion.

I restarted Workspace Desktop, added the two lines to my Python code, and tried to open a session (all in my local Python environment). I am attaching the logs below as a .txt file, as they otherwise would exhaust my character limit in my reply.

I can also confirm that opening "About LSEG Workspace" in the Workspace Desktop, clicking on "Data API Proxy" shows the red "Unavailable" status.

I would be grateful about more ideas.

logs.txt

logs.txt (1.4 KiB)

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.