question

Upvotes
Accepted
5 4 2 3

Getting No data in cache as message/reason when using canned data EMEA with sink_drive_src for EMA runconsumer100 sample program

I am trying to execute the runConsumer100 example from EMA tutorial against the Canned data set of EMEA using the sink_driven_src infra tool. So runConsumer100 is successfully getting connected to localhost and port 14002 with the canned data but I receive below message rather than proper response saying "No data in cache", but the canned data set contains 312799 messages:

WARNING: loggerMsg
    ClientName: ChannelDictionary
    Severity: Warning
    Text:    RDMDictionary stream was closed with status message
        streamId 4
        Reason State: Closed/Suspect/None - text: "No data in cache."
loggerMsgEnd

runConsumer100 is from the eample section of EMA:

https://developers.thomsonreuters.com/elektron/elektron-sdk-java/quick-start?content=43056&type=quick_start

As per the link above, I should receive the field records for refresh and update.

To get the response from canned data, sink_driven_src is used using the bat file which contains below command:

..\win_x86_64\sink_driven_src.exe -S DIRECT_FEED -bdf emeaData.dat -U 1 -N 14002 -K -ik -t 361
pause
elektronrefinitiv-realtimeelektron-sdktreprrtema-apielektron-message-apisink-driven-source
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Upvotes
Accepted
25k 87 11 23

Hi @amar.a.panigrahi

Have you changed the example code to request one of the RICs included in the actual canned data file - as listed in the readme.html file?

The example requests 'IBM.N' by default - but this is not included in the EMEA canned data file.

Regards.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hey Thanks Umer for prompt reply. As you said have checked the readMe.html and found the list of RIC. Have then tried with LLOY.L ric by updating it in Consumer class but still it gave the same message.

Ok, and have you also changed the EMAConfig.xml to use local data dictionary as described in section 6 of the readme.html.

Looking more closely at your Warning above, it is the Data Dictionary that it cannot get from the the canned data.

Please ensure the EMAConfig.xml is in the working directory to ensure the changes are picked up.

Hey Thanks, I got the expected response now. I copied it earlier within the series 100 folder, however working folder would be the one from which the program is generally executed and this has clicked in my mind now. So i copied it in EMA/examples folder which is the base for execution using gradle and then it worked. Thanks a lot :)

Show more comments