question

Upvotes
Accepted
1 1 1 2

emaj 3.4.0 tcp_nodelay socketopt set to False

Hi

We are using emaj3.4.0.L1.all.rrg and encountered problem with ommInteractive provider where the tcp_nodelay socketopt is either always set to False or omitting True value.

ommNIP and ommConsumer components do not experience such behavior and set the tcp_nodelay flag appropriately.


Can you advise where the problem may be.

Thanks

Piotr

elektronrefinitiv-realtimeelektron-sdkrrtema-apielektron-message-apitcp
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
47.2k 110 44 60

@piotr.g

I have verified the code. EMA Java may not use the TcpNodelay parameter when creating a server socket.

It should have this line in order to set tcp_nodelay.

_bindOptions.tcpOpts().tcpNoDelay(((SocketServerConfig)_activeServerConfig.server
Config).tcpNodelay);

You have two options:

1. Contact RDC subscribers inside your company in order to submit a new case to RDC via Contact Premium Support at https://developers.refinitiv.com/elektron/elektron-sdk-java

RDC will investigate this issue and then contact the development team if it is a bug in the API.

2. Raise this issue via GitHub as mentioned by my colleague


1593599312697.png (38.3 KiB)
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Thanks for the info, I'll pass it to our Dev team

Upvotes
9.5k 10 5 7

Hello @piotr.g

Have you tried emaj the latest version, 3.5.0.0, shipped with Elektron SDK - Java - 1.5.0.L1 package yet?

If the problem still occur with the latest version, you can submit the issue to the development team directly via Elektron-SDK Github

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.