For a deeper look into our Eikon Data API, look into:

Overview |  Quickstart |  Documentation |  Downloads |  Tutorials |  Articles

question

Upvotes
65 1 2 4

Delay in Subscription and Requested OHLC data - US Equity Market opening phase

Hi,
I have issues with requesting historical bars(ohlc) as well as with timeseries subscription via the .net API. It mainly happens when the US stock market opens at 9:30 EST for about 15 minutes. When I request historical bars, it can take up to 10 minutes before I get a response. During normal operation, this sort of request is responded to within 50 ms to 200 ms.

When I subscribe to bar updates/Timeseries subscription, that for the first up to 7 minutes, some instruments/stocks do not update the data - do not fire an event within the API.

Currently, I am monitoring these symbols:

"AAPL" "ADBE" "AMAT" "AMD" "AMGN" "AMZN" "AVGO" "CHTR" "COST" "GOOGL" "INTC" "INTU" "META" "MSFT" "NFLX" "NVDA" "PEP" "PYPL" "QCOM" "SBUX" "TMUS" "TSLA" "TXN" "ZM"

And then I subscribe the rics with an O (‘*.O’ ) at the end, like this ADBE.O .

I did not post any code snipplets here, since above issues normally vanish after 15 minutes of the US Equity markets are open - 9:45 EST - so code works flawlessly.

My assumption is, that there is not enough computing power when the US market opens.

Any idea on how to improve this?


Thanks for your support.
Mike


c#.nettimeseries
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

@tt1057

Please specify the API that you are using.

Is it App Studio - .NET SDK?

The code looks like this:

private ITimeSeriesDataService _timeSeries;
private void Initialize(){
    _timeSeries = DataServices.Instance.TimeSeries;
    _timeSeries.ServiceInformationChanged += timeSeries_ServiceInformationChanged;
}
private void timeSeries_ServiceInformationChanged(object sender, ServiceInformationChangedEventArgs e){
    Debug.Print("{0}: {1}", e.Information.State, e.Information.Message);
}

1 Answer

Upvotes
65 1 2 4

Hi, thanks for the follow up.

Yes, something has improved greatly. The delay seems to be gone for most of the symbols.

Currently, I only experience issues 4 out of 5 days, with these symbols:
SBUX.O and MSFT.O .I need to subscribe them up to 10 times, before they are bringing data to me.


Thanks for your support in the background!

Mike

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.