For a deeper look into our Eikon Data API, look into:

Overview |  Quickstart |  Documentation |  Downloads |  Tutorials |  Articles

question

Upvotes
Accepted
5 6 4 7

Repeated Timeouts

Is there a way to modify the timeout parameter in the eikon api ? I am getting a lot of Request Timeouts and it usually works when I restart the program. Internet connectivity and speed is not the issue here. Can someone please guide me in case there is a way to increase the timeout for connection on Eikon API or should I be looking at something else ?

eikon.eikonError.EikonError: Error code 408 | Request timeout occured

eikoneikon-data-apipythonworkspacerefinitiv-dataplatform-eikonworkspace-data-apiconnection
icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
Accepted
5 6 4 7

Actually I decided to modify the API and then discovered that there is a configureable timeout. I am using it and seems to be working as expected.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Great. Thanks for the update.

Upvotes
13.7k 61 39 63

Hi @abbanerjee,

There is no timeout parameter you can modify unfortunately. I would suggest instead reduce the amount of data in your request by limiting the timeframe (date range for example). See this thread for related question.

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Upvotes
5 6 4 7

How about using set_timeout in the API ?

icon clock
10 |1500

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Hi @abbanerjee,

Thank you for pointing this out. I have not tried this but according to the documentation it should do what you may need. Did you try it?